1996 Landrover Range Rover 4.6 - Skips

Specific repair issues for other imported vehicles
Locked
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

1996 Landrover Range Rover 4.6 - Skips

Post by jbadenoch »

well.... it looks like I just don't learn. After my last experience with a landrover I'm thinking I should just keep a stick of dynamite as a tool for them. This one was sent to us by another shop (yeah, I'm a sucker for those) was skipping badly on bank b and they had diagnosed it with a clogged catalytic converter. We tested them and they were not blocked. The customer wanted us to diagnose it. The reading from our Verus showed 0 GPH on the MAF. We did a component test on it and it was sending a good signal, and had power and ground. We back probed the connection at the ECU and it was reading there as well. At this point we believe it has a bad ECU. Any thoughts or suggestions here would be appreciated.
User avatar
brianp87
3K Time Lord Contributor
3K Time Lord Contributor
Posts: 3118
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona
Contact:

Re: 96 landrover rangerover 4.6

Post by brianp87 »

Sounds like your on the right path to me. If the maf has a good signal sweep with the correct voltage and it sees it into the comp but not out of it then thats what you would think.
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

Re: 96 landrover rangerover 4.6

Post by jbadenoch »

Just being nervously cautious.
User avatar
ricmorin
5K Holy Smokes Contributor
5K Holy Smokes Contributor
Posts: 5801
Joined: Mon Jul 25, 2005 10:11 am
Location: New Hampshire
Contact:

Re: 96 landrover rangerover 4.6

Post by ricmorin »

And rightfully so. I would ask that you consider this: the lack of a signal may actually be a problem with the Verus. Before I put a part in that LR, I'd confirm it with a different scan tool. LR's are very finicky.
Ric Morin - Volunteer Forum Moderator, Shop Owner, ASE Master L1
Motorcar Alternatives, LLC
603-622-6434 x203
www.motorcaralternatives.com

I find my life is a lot easier when I use Special Orders
User avatar
brianp87
3K Time Lord Contributor
3K Time Lord Contributor
Posts: 3118
Joined: Tue Oct 10, 2006 6:11 am
Location: Arizona
Contact:

Re: 96 landrover rangerover 4.6

Post by brianp87 »

Good point
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

Re: 96 landrover rangerover 4.6

Post by jbadenoch »

I agree and know the lr's are finiky. Unfortunatly I don't have any good contacts for someone with another brand of scanner. Plenty of snapons, no other brands... dealer is not helpful. Still hesitating to pull the trigger.
User avatar
steven kiser
5K Holy Smokes Contributor
5K Holy Smokes Contributor
Posts: 6184
Joined: Fri Jul 06, 2007 4:58 am
Location: eastern ma.

Re: 96 landrover rangerover 4.6

Post by steven kiser »

Yank a main feed from air plenum hose between sensor and intake or un clamp and pull hose away a bit. This has to be on the engine side if sensor. See how it reacts. Could also be an intake issue.
never argue with a fool, they'll drag you down to their level and beat you with experience
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

Re: 96 landrover rangerover 4.6

Post by jbadenoch »

steven kiser wrote:Yank a main feed from air plenum hose between sensor and intake or un clamp and pull hose away a bit. This has to be on the engine side if sensor. See how it reacts. Could also be an intake issue.
Steve, I assume by "see how it reacts" that you mean by providing un-metered air that it will run differently if maf is reading and no difference in runnability if its not?
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

Re: 96 landrover rangerover 4.6

Post by jbadenoch »

Well steve, I pulled the air duct loose while running and it stalled right out. Makes me think your right about a finiky landrover ecm and not wanting to give up the info. One issue still bothers me however, when unplugging maf there is no difference in runnability. ????????? puzzled and exploring other avenues. I'll keep ya posted on this pos.
Locked

Return to “Imports - Other”