1998 Suzuki Esteem 1.6 AT - No Start

Specific repair issues for other imported vehicles
Post Reply
Kyle2986
Member
Posts: 4
Joined: Fri Dec 01, 2006 12:56 pm
Location: Michigan

1998 Suzuki Esteem 1.6 AT - No Start

Post by Kyle2986 »

Another shop installed spark plugs and wires on vehicle for maint. Customer drove vehicle for a couple days than it would not start. They had it towed back to the original shop and they thought it was a bad ECM but werent sure. Customer had vehicle towed to us and the vehicle was lacking spark, Injector pulse and check engine light would not come on when keyed up. Tech confirmed ECM had all powers and grounds including from ignition switch. Diagnosed as a faulty ECM. New ECM cost was $3500. Customer opted to install a used one due to cost. Installed ECM vehicle started and ran, test drove several times. Customer took vehicle for approx 2 weeks then it was towed in as a crank no start. All same condition apply above. Assumed it was another bad ECM. Installed a secound used ECM with same result except this time it lasted approx 3 weeks and was towed back in. This time technician installed original ECM and first used ECM and vehicle still would not start. Battery was left disconnected over night. Battery was connected in morning and engine will now start and run. It has started and ran in shop for two days. Vehicle does not have factory antitheft or after market alarm systems. Checked ground connections at engine, body and battery and test fine. Do not want to let customer take vehicle again with out knowing what is causing the ECM faults.
User avatar
ricmorin
5K Holy Smokes Contributor
5K Holy Smokes Contributor
Posts: 5801
Joined: Mon Jul 25, 2005 10:11 am
Location: New Hampshire
Contact:

Re: 1998 Suzuki Esteem 1.6 Auto

Post by ricmorin »

Which ECM is in it now? Sounds like a shorted device pulling the driver down and confusing the ECM.
Ric Morin - Volunteer Forum Moderator, Shop Owner, ASE Master L1
Motorcar Alternatives, LLC
603-622-6434 x203
www.motorcaralternatives.com

I find my life is a lot easier when I use Special Orders
User avatar
steven kiser
5K Holy Smokes Contributor
5K Holy Smokes Contributor
Posts: 6184
Joined: Fri Jul 06, 2007 4:58 am
Location: eastern ma.

Re: 1998 Suzuki Esteem 1.6 AT - No Start

Post by steven kiser »

I may be confusing A Suzuki with another rice burner but there was one where a harness needed to be moved to replace plugs and wires. Wires would break =in the harness causing all sorts of issues. If a ground wire were to brake that fed a sensor attached to the pcm it may in fact trash the kam and when all power is removed from the pcm and capacitors flatten the pcm will revert to a limp, function and relearn. During operation if there is a loss of ground to a sensor it will kill the vehicle and later allow it to restart. I've seen this in Mercedes where the harness goes through the fire wall near the wiper bunker, in Isuzu's were the harness laid over the engine on six cylinders. Sounds like a broken wire in a harness. The harness may need to be opened and wires looked at individually. Customer may need to be well informed about this. I've opened up harnesses to find all the wires so brittle they snap like pretzels.
never argue with a fool, they'll drag you down to their level and beat you with experience
jbadenoch
400 Club: Mega-Star Contributor
400 Club: Mega-Star Contributor
Posts: 481
Joined: Thu Sep 23, 2010 8:48 am
Location: greenville sc

Re: 1998 Suzuki Esteem 1.6 AT - No Start

Post by jbadenoch »

I'm thinking crank sensor. Had couple others here in the last couple years with similar issues, and both needed crank sensors. May need to just change and see, due to lack of frequency of symptom. Hate educated guesses but sometimes have little choice. Good luck and keep us posted as to the fix
Post Reply

Return to “Imports - Other”